Hi:
I am trying to get Ruby and Tk working (as in Ch15 of
the pickaxe book). The Tk extensionis supposed to be bundled
in the main distribution, but I get the error below
about the missing libtk.so file when trying to run
the Hello World program.

./hw.rb
/usr/local/lib/ruby/1.6/tk.rb:7:in `require': ld.so.1:
/usr/local/bin/ruby: fatal: libtk.so: open failed: No such file or
directory - /usr/local/lib/ruby/1.6/sparc-solaris2.6/tcltklib.so
(LoadError)
        from /usr/local/lib/ruby/1.6/tk.rb:7
        from ./hw.rb:3:in `require'
        from ./hw.rb:3

I have the following libs
find /usr -name tcltklib.so
/usr/local/lib/ruby/1.6/sparc-solaris2.6/tcltklib.so
ls /usr/local/lib/ruby/1.6/sparc-solaris2.6/*tk*
/usr/local/lib/ruby/1.6/sparc-solaris2.6/tcltklib.so*
/usr/local/lib/ruby/1.6/sparc-solaris2.6/tkutil.so*

Do I just need to make a soft link to a lib and name
it libtk.so?

Thanks
=========================================================
Jim Freeze
jim / freeze.org
---------------------------------------------------------
No comment at this time.
http://www.freeze.org
=========================================================