Conrad Schneiker writes:
> From: Dave Thomas <Dave / thomases.com>
> 

...

> Could we (the readers of this newsgroup)--in the interest of learn-ability,
> teach-ability, comprehensibility, public friendliness, principle of least
> surprise, not using Perl-like obscurities (e.g. bless), and everything else
> that otherwise makes Ruby great--could we all agree on a better name for the
> yield statement that would also be acceptable to Matz, and which could
> co-exist for a year or so with a depreciated yield?

Sorry, but I do not think, that a 'yield' should be deprecated. If we
introduce a new statement besides 'yield', then ok! But we should not
going the way to bear impression that Ruby is a new born language,
IMHO. We can add new features, but we should not delete old ones;
especially not *reserved keywords*! For all other changes, we should
very careful!

Ruby exists already for some years. Many people have used it to write
applications. In Japan, Ruby has thrown away Python for
programming. We should not come and change all this, because we do not
like 'yield'. 'yield' is a key feature of Ruby. So the chance that
much software has to be changed because of this deprecation, is high!

I, for example, have no time to search and change all my software
based on this. If I would try, my boss would ask me very seriously, if
I think Ruby could be called 'finished' (in terms of ready-to-use), or
if we should wait for one or two years. And then, he would not agree
any longer, that I use it.

Okay, all these applications could be changed by script, but also this
involves much overhead. For example: all our programs are under
version control, and not directly accessible to the developer after
delivery. Too much trouble, I fear :-(

> 
> At the moment, I strongly prefer callBlock because it is syntactically
> self-documenting.

I do not like this word. No that is not true! I do not like the
'wordWord' construct. Pffffhhh also not true. Before Ruby, I has used
this 'wordWord' wording very often because I am too lazy to type the
'_' ;-) But since I am programming Ruby I have changed my mind. That
does not mean I do not use it anymore, but not in Ruby.

Ruby use these wording only for class/module names. all methods are
written in lower case with '_' between the words. Your 'callBlock'
does not fit into this scheme! Ruby should consistent here.

So my conclusion is: Let it as it is! If there should be a new
keyword, than something like 'call_block'. The name of the new keyword
has to fit into the current naming scheme. But *please* do not let
'yield' die!!! That would be a wrong decision, I fear. I would give
Ruby the glance of an unfinished language.

> 
> Group?
> 
> Conrad
> 
> (PS: likewise, can we agree to describe "destructive methods" as "change
> methods"?)

This would be better, IMHO. 'Destructive' means for me:
destruct/destroy the object. But it is changed really! So I would vote
for it!

Just my two cents!

\cle

-- 
Clemens Hintze  mailto: c.hintze / gmx.net