W. Kent Starr wrote:
| On Monday 30 April 2001 02:41, Guillaume Rumeau wrote:
| > matz / zetabits.com (Yukihiro Matsumoto)
| >
| > a $BqD(Brit le 04/30/01 05:53:16 que :
| > > Hi,
| > >
| > > In message "[ruby-talk:14339] gtk and Float/to_f"
| > >
| > >     on 01/04/28, Thomas Lundqvist <thomasl / ce.chalmers.se> writes:
| > > |Hi! I experience the following strange behavior:
| > > |> ruby -e 'puts "5.3".to_f + 1.0'
| > > |
| > > |6.3
| > > |
| > > |> ruby -e 'require "gtk"; puts "5.3".to_f + 1.0'
| > > |
| > > |6.0
| > >
| > > Weird.  Platform information, please?
| > > Nothing changes on ruby 1.6.3 (2001-03-28) [i386-linux].
| >
| > Hi, i have the same strange behaviour :
| >
| > $>ruby -v
| > ruby 1.6.2 (2000-12-25) [i686-linux]
| >
| > $>gtk-config --version
| > 1.2.7
| >
| > $>uname -a
| > Linux leon 2.4.4 #1 Sat Apr 28 18:33:42 CEST 2001 i686 unknown
| 
| 
| And I do not :>?
| 
| unknown terminal "emacs"
| [wyzzrd@starcrusher dialogs]$ ruby -e 'puts "5.3".to_f + 1.0'
| 6.3
| [wyzzrd@starcrusher dialogs]$ ruby -e 'require "gtk"; puts 
| "5.3".to_f + 1.0'
| 6.3
| [wyzzrd@starcrusher dialogs]$ ruby -v
| ruby 1.6.2 (2000-12-25) [i586-linux]
| [wyzzrd@starcrusher dialogs]$ uname -srm
| Linux 2.2.14-5.0 i586
| [wyzzrd@starcrusher dialogs]$ gtk-config --version
| 1.2.8
| [wyzzrd@starcrusher dialogs]$
| 
| diffs are i586 instead of i686 and 1.28 gtk instead of 1.27.
| 
| Matz wrote:
| 
| > Nothing changes on ruby 1.6.3 (2001-03-28) [i386-linux]
| 
| Yeah, but _Intel_ has a 'history' :-)

I get this in from my prompt:

--
Microsoft(R) Windows 98
   (C)Copyright Microsoft Corp 1981-1999.

C:\WINDOWS>ruby -e 'puts "5.3".to_f + 1.0'
6.3
C:\WINDOWS>ruby -e 'require "gtk"; puts "5.3".to_f + 1.0'
6.3
C:\WINDOWS>ruby -v
ruby 1.6.2 (2000-12-18) [i386-cygwin]
C:\WINDOWS>ruby -w -e 'require "gtk"; puts "5.3".to_f + 1.0'
6.3
--

gtk is version 0.23
The Ruby distro is the Pragmatic's Windows-installer (1.6.2-03)

Dennis Decker Jensen