matz / zetabits.com (Yukihiro Matsumoto)
a ˝─rit le 04/30/01 05:53:16 que :

> Hi,
> 
> In message "[ruby-talk:14339] gtk and Float/to_f"
>     on 01/04/28, Thomas Lundqvist <thomasl / ce.chalmers.se> writes:
> 
> |Hi! I experience the following strange behavior:
> |
> |> ruby -e 'puts "5.3".to_f + 1.0'
> |6.3
> |
> |> ruby -e 'require "gtk"; puts "5.3".to_f + 1.0'
> |6.0
> 
> Weird.  Platform information, please?
> Nothing changes on ruby 1.6.3 (2001-03-28) [i386-linux].
> 

Hi, i have the same strange behaviour :

$>ruby -v
ruby 1.6.2 (2000-12-25) [i686-linux]

$>gtk-config --version
1.2.7

$>uname -a
Linux leon 2.4.4 #1 Sat Apr 28 18:33:42 CEST 2001 i686 unknown


-- 
GR <guillaume.rumeau / wanadoo.fr>

L'homme est doud'une vaste intelligence 
qui regarde devant elle et au-del(J.L)