In message <V6Oke.25440$795.785654 / twister1.libero.it>,
 `gabriele renzi <surrender_it / remove-yahoo.it>' wrote:
> Anyway, trying to build the preview release of ruby 1.8.3 on an old 
> debian box, I get this two warnings for ext/openssl:
(snip)
> ossl_cipher.c: In function `ossl_cipher_pkcs5_keyivgen':
> ossl_cipher.c:208: warning: passing arg 2 of `EVP_BytesToKey' discards 
> qualifiers from pointer target type

The main target of ext/openssl is OpenSSL-0.9.7.
Some warnings appear if 0.9.6 is used.  But I think these
are not serious problem.

regards,

-- 
gotoyuzo