You do not need termios for Windows, so you might try:
gem install highline --ignore-dependencies

HTH