Possibly avoiding the issue, one workaround might be building your own
ruby 1.8.2 in /usr/local and using that instead of the Apple version. I
haven't tried on Tiger but the build was simple on Panther (./configure
; make; sudo make install), and I've generally had better luck with
self-compiled versions of langs included with OS X (like ruby, python,
etc.)