pat allan wrote:
> .. from what I can tell, that's because the mac version of MySQL
> doesn't come with libmysqlclient.so - apparently the only way to get
> that is to build mysql from source, which i'd like to avoid if
> possible.

Well, I did not yet install it here on Tiger, but it would be 
libmysqlclientX.dylib instead of .so, try to look for it by using 
"mdfind" or "locate".

> gcc -fno-common -arch i386 -arch ppc -g -Os -pipe -fno-common -arch
> i386 -arch ppc -pipe -pipe -fno-common  -I.
> [...]
> 'i686' looks strange to me. The version of gcc is 4.0.0 - if I run the
> above gcc command with gcc-3.3 it comes up with a single line:

The hole compiler command seems messed. You really need to kick the 
"-arch i386" out of the line.

Kind regards,
Philipp Kern