From: Dave Thomas <Dave / thomases.com>
Subject: [ruby-talk:01417] Re: Yield

> "Conrad Schneiker" <schneiker / jump.net> writes:

> > At the moment, I strongly prefer callBlock because it is syntactically
> > self-documenting.
>
> I could live with it, although I confess I don't really have a problem
> with 'yield'

OK, so that's 2 votes for callBlock.

> Although I think "destructive methods" is not
> right, I feel that "change methods" is just too vague.  If we're going
> to alter the name, my first vote would go with 'mutators'. That seems
> to be pretty standard in the C++ and Java worlds.

That's a very large and highly relevant crowd, and mutator is at least a big
step in the right direction, so, OK.

From: Dave Thomas <Dave / thomases.com>
Subject: [ruby-talk:01422] Re: Scripting versus programming

> ps. mutator....  ;-)

OK, so that's 3 votes for mutator. :-)

Regards,

Conrad