Hi,
On my pc there is debian-unsable and I've manually installed the
version 1.8.2 (20041225) of Ruby because if I use apt-get there is the
version 1.8.2-7 that isn't compatible with many gems.
In debian there are several packages that need ruby and then to use
them I need to mark ruby as installed with equivs.
I've tried to write the ruby control file for equivs but I haven't
found the way to mark as installed all the packages needed. Looking at
the dependencies seems that the following equivs control file should be
enough but it marks only the package ruby and then when I use apt-get
to install any package that need ruby (art-gnome for example) it try to
install libruby1.8.

****
Section: misc
Priority: optional
Standards-Version: 3.5.10

Package: ruby
Version: 1.8.2-1
Provides: ruby, ruby1.8, libruby1.8, libreadline-ruby1.8, ruby1.8-dev,
libtcltk-ruby1.8, ruby1.8-examples, libgdbm-ruby1.8, ri1.8,
ruby1.8-elisp, libruby1.8-dbg, ruby1.8, libruby1.8, rdoc1.8, irb1.8,
libopenssl-ruby1.8, libdbm-ruby1.8

****

Is there someone that have had the same problem? Can you send me your
equivs file?
Thanks in advance.

Giannandrea