On 5/8/05, Yukihiro Matsumoto <matz / ruby-lang.org> wrote:
> I'd like to emphasize the "per-object" attribute of the object.
> Ideally, the term should be "xxxx class" where
> 
>   * xxxx describe the class is per-object.
>   * xxxx is an adjective, or a noun that can be used like adjective.
>   * we can call methods now we call "singleton methods" as xxxx
>     methods for consistency.

How about "self"?

  "self class"
  "self methods"
  obj.self_class

or "solo"?

  "solo class"
  "solo methods"
  obj.solo_class

Chris