"Conrad Schneiker" <schneiker / jump.net> writes:

> At the moment, I strongly prefer callBlock because it is syntactically
> self-documenting.

I could live with it, although I confess I don't really have a problem 
with 'yield'

> (PS: likewise, can we agree to describe "destructive methods" as "change
> methods"?)

This one I don't like. Although I think "destructive methods" is not
right, I feel that "change methods" is just too vague.  If we're going
to alter the name, my first vote would go with 'mutators'. That seems
to be pretty standard in the C++ and Java worlds. I know 'mutator' is
a $2 word, but it seems better to me.


Regards

Dave