Hi,

>From: Daniel Berger <djberge / qwest.com>
>Reply-To: ruby-talk / ruby-lang.org
>To: ruby-talk / ruby-lang.org (ruby-talk ML)
>Subject: Re: Can't build Ruby 1.8.2 on Sparc Solaris 10
>Date: Fri, 6 May 2005 23:05:31 +0900
>
>
>Odd, I had no problem building Ruby on my Solaris 10 box:
>
> >gcc -v
>Reading specs from /usr/sfw/lib/gcc/sparc-sun-solaris2.10/3.4.3/specs
>Configured with: 
>/gates/sfw10/builds/sfw10-gate/usr/src/cmd/gcc/gcc-3.4.3/configure 
>--prefix=/usr/sfw --with-as=/usr/sfw/bin/gas --with-gnu-as 
>--with-ld=/usr/ccs/bin/ld --without-gnu-ld --enable-languages=c,c++ 
>--enable-shared
>Thread model: posix
>gcc version 3.4.3 (csl-sol210-3_4-branch+sol_rpath)
>
>That's the gcc that comes from blastwave.org (I highly recommend their 
>packages btw).
>
>What version of make are you using?  Perhaps you're using GNU's make with 
>Sun's linker and that's causing an issue, but this isn't the typical error 
>I would expect from that.  Otherwise, I can only recommend upgrading your 
>gcc using the blastwave package and trying again.
>
I had installed gcc from sunfreeware.com binary package.

I have upgraded gcc using the blastwave package.
Now building is OK and ruby works fine.

Thanks,

Park Heesob

_________________________________________________________________
Don't just search. Find. Check out the new MSN Search! 
http://search.msn.click-url.com/go/onm00200636ave/direct/01/