Ara.T.Howard / noaa.gov wrote:
>> Any ideas what is wrong here?
> 
> possibly you have two rubys - perhaps 1.6 and 1.8.  you may have 
> installed it
> for one and not the other.  do you have two rubys?

Yes, the 1.8.1 and 1.8.2, /usr/local/bin/ruby is 1.8.2.

The problem seems to have resolved itself, which it can't have done by 
itself.  I must have done something...

I can now:

require 'dbi'

and it works, or:

require 'rubygems'
require 'postgres'

works now too.  Huh.  Thanks for the responses.

Will.