On 4/18/05, Brian Buckley <briankbuckley / gmail.com> wrote:
> Hello,
> 
> I am getting an error when I attempt to install the "facets" gem. When I
> enter
> 
> gem install facets
> 
> I get the following error message:
> ERROR: While executing gem ... (Errno::EINVAL)
> Invalid argument - llib/facet/nil/empty?
> 
> Are others seeing this (or am I guilty of user error)?
> 

Brian, am I right to guess that you are running Windows?  Looks like
Facets has files called, for example, "empty?.rb", which is not valid
on Windows.  I don't know of a way that you can get Facets to run on
Windows if that's the case, but perhaps its author has prior
experience making it work.

-- 

Chad Fowler
http://chadfowler.com
http://rubycentral.org 
http://rubygarden.org 
http://rubygems.rubyforge.org (over 100,000 gems served!)