On 4/17/05, Navindra Umanee <navindra / cs.mcgill.ca> wrote:
> David Heinemeier Hansson <david / loudthinking.com> wrote:
> > Of course, when RubyGems is included in 1.8.3 (hopefully or, pain,
> > pain, 1.8.4), I think that's when RubyGems will make its mark for
> > increasing the first-time visit of libraries on newbies coming to Ruby.
> 
> Oh no, RubyGems is going to be included by default in Ruby? :(
> 
> No offense, but I would really hate to *have* to use those stupid
> looking RubyGem requires to use Ruby libraries...
> 

You miss the point:  if RubyGems were included in Ruby's default
distribution, it would be integrated, and you'd never have to use
require_gem again (though, you could still use require_gem to load a
specific version of a library).

-- 

Chad Fowler
http://chadfowler.com
http://rubycentral.org 
http://rubygarden.org 
http://rubygems.rubyforge.org (over 100,000 gems served!)