Thank you Austin!

I've found and tried out this one:

http://rubyforge.org/tracker/index.php?func=detail&aid=865&group_id=167&atid=715

... <snip>
I had the same problem under WinXP in Germany.

My fix:
run the command "set HOME=%HOMEPATH%"
Then create a file in your HOMEPATH called .inputrc with this
content:
"\M-[": "["
"\M-]": "]"
"\M-{": "{"
"\M-}": "}"
"\M-\\": "\\"
"\M-|": "|"
"\M-@": "@"
"\M-~": "~"
<snap> ...

This does not fully work with a danisk keyboard.

1) I have a few more characters where using Left-ALT is necessary.
I tried to add those, and succeeded except for ".

2)In order to type "~" I have to type Left-ALT-~ + spacebar
(2 strokes) during "normal" keyboard operation.
Using IRB, I get one strange "grafic"-character followed by "~".
Same thing happens for "|".
-------------


I would like to know what the "patch" is actually doing?

And in what module?
-------------

But I can probably live with this for a while. Until I know so
much about Ruby that I can make up my mind about continuing. 

Thanks again.

Regards Steffen
+ + + + + + +


Austin Ziegler wrote:
> On Fri, 25 Mar 2005 03:25:13 +0900, Steffen Pedersen <eskape / tdcadsl.dk> wrote:
> 
>>I'm using Win 2000 Pro (english language) with a danish
>>keyboard layout.
> 
> 
> This is the problem -- please search on the archives for IRB and
> German -- there are some alternative .irbrc files that should help
> with this problem. I believe that this is a high priority item for
> Curt to fix in the next release of the Windows installer.
> 
> -austin