"Erik Veenstra" <google / erikveen.dds.nl> writes:

>> IMO, the best thing is
>>
>>   begin
>>     require 'rubygems'
>>   rescue LoadError
>>   end
>
> Why? I bet you foresee something I missed.

You don't need to have gems installed; you can simply install the
libraries (assuming they have the same name as the gems).  And, you
don't need to have RUBYOPTS set.

I don't think there is an easier way.

> gegroet,
> Erik V.
-- 
Christian Neukirchen  <chneukirchen / gmail.com>  http://chneukirchen.org