I'm writing a very simple FxRuby application. When I run it on a newer
version of FxRuby I need to require 'fox12'. When I run it on an older
version, it needs require 'fox'. It seems to work fine on both
environments except that that I need to change the require. I want to
make the application generic so that it runs on both environments by
doing something like:


if require 'fox'
    require 'fox'
    require 'fox/colors'
    include Fox
elsif require 'fox12'
    require 'fox12'
    require 'fox12/colors'
    include Fox
else
    # do something different   
    exit
end


However, this doesn't work -> LoadError: No such file to load -- fox.
How can I overcome this problem.