On Sat, 26 Mar 2005 00:28:25 +0900, Lasse Koskela
<lasse.koskela / gmail.com> wrote:
> Darn. Sorry about the subject of my previous email.
> 
> -Lasse-
> 
> On Fri, 25 Mar 2005 17:11:37 +0200, Lasse Koskela
> <lasse.koskela / gmail.com> wrote:
> > Hi all,
> >
> > I just tried to install Rails with gem and got this nasty error:
> >
> > C:\ruby\bin>gem install rails --remote
> >
> > C:\ruby\bin>"c:\ruby\bin\ruby.exe" "c:\ruby\bin\gem" install rails --remote
> > Attempting remote installation of 'rails'
> > Updating Gem source index for: http://gems.rubyforge.org
> > Install required dependency rake? [Yn]  y
> > Install required dependency activesupport? [Yn]  y
> > Install required dependency activerecord? [Yn]  y
> > Install required dependency actionpack? [Yn]  y
> > Install required dependency actionmailer? [Yn]  y
> > Install required dependency actionwebservice? [Yn]  y
> > c:/ruby/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in
> > `require__': No such file to load -- iconv (LoadError)
> >         from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in
> > `require'
> >         from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.0.2/lib/active_support/dependencies.rb:197:in
> > `require'
> >         from c:/ruby/lib/ruby/gems/1.8/gems/actionmailer-0.8.0/lib/action_mailer/vendor/tmail/quoting.rb:1
> >         from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in
> > `require__'
> >         from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in
> > `require'
> >         from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.0.2/lib/active_support/dependencies.rb:197:in
> > `require'
> >         from c:/ruby/lib/ruby/gems/1.8/gems/actionmailer-0.8.0/lib/action_mailer/vendor/tmail/mail.rb:18
> >         from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in
> > `require__'
> >          ... 20 levels...
> >         from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:90:in
> > `process_args'
> >         from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:63:in `run'
> >         from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:9:in `run'
> >         from c:/ruby/bin/gem:11
> >
> > C:\ruby\bin>gem install rails --remote
> >
> > C:\ruby\bin>"c:\ruby\bin\ruby.exe" "c:\ruby\bin\gem" install rails --remote
> > Attempting remote installation of 'rails'
> > c:/ruby/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in
> > `require__': No such file to load -- iconv (LoadError)
> >         from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in
> > `require'
> >         from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.0.2/lib/active_support/dependencies.rb:197:in
> > `require'
> >         from c:/ruby/lib/ruby/gems/1.8/gems/actionmailer-0.8.0/lib/action_mailer/vendor/tmail/quoting.rb:1
> >         from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in
> > `require__'
> >         from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in
> > `require'
> >         from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.0.2/lib/active_support/dependencies.rb:197:in
> > `require'
> >         from c:/ruby/lib/ruby/gems/1.8/gems/actionmailer-0.8.0/lib/action_mailer/vendor/tmail/mail.rb:18
> >         from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in
> > `require__'
> >          ... 20 levels...
> >         from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:90:in
> > `process_args'
> >         from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:63:in `run'
> >         from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:9:in `run'
> >         from c:/ruby/bin/gem:11
> >
> > Also, running "ruby -version" produces an error, which I guess could be related:
> >
> > C:\ruby\bin>ruby -version
> > ruby 1.8.2 (2004-12-25) [i386-mswin32]
> > -e:1: undefined local variable or method `rsion' for main:Object (NameError)
> >
> > I had just downloaded and installed the Ruby 1.8.2-14 Windows installer.
> >
> > My experience with Ruby has so far been playing around with small
> > hello world'ish scripts so I'd obviously be thankful for any hints
> > towards what's wrong in my setup.
> >
> > Thanks.
> >
> > -Lasse-
Hi,

I had the same problem.Download the latest version of rubygems which
is rubygems-0.8.8.You would find a file called setup.rb.

Perform ruby setup.rb at the command prompt,which would install a few
things by itself.

sometimes it requires cleaning up your old setup.So u might need to
install ruby again.And then go about installing rubygemsand the steps
mentioned above.

Do lemme know if this works.Thanks
Regards
Ramya