Daniel Amelang wrote:
> I entirely prefer getting rid of the {} empty hash constructor
> (leaving us only Hash.new) than the adding block syntax with empty
> pipes {|| puts 'eek'}. If the {} hash constructor is the *only* thing
> between us and making {} refer to blocks and blocks only, I think
it's
> worth the loss.
>
> Alternatively, you could make [:] the empty hash constructor. Quite a
> shortcut for an associative array, if I do say so myself :)
>
> Dan

I vote we leave well enough alone.  All this mess so we can avoid
typing the word "proc"?

As I think David Black mentioned in one of his posts, this doesn't feel
like a unification of the proc/lambda/Proc/block syntax.  It feels more
like we're just shifting ownership of "{}" to another class.

Towards what end is this heading?

Regards,

Dan