Hi,

Was a resolution ever found for this problem?

Cheers,

Thomas

On Mon, 07 Feb 2005 21:14:43 +0000, itsme213 wrote:

> [C:\ruby\lib\ruby\gems\1.8\gems]gem install rubygems-update --backtrace
> Attempting local installation of 'rubygems-update'
> Local gem file not found: rubygems-update*.gem
> Attempting remote installation of 'rubygems-update'
> ERROR:  While executing gem ... (Zlib::BufError)
>     buffer error
> C:/ruby/lib/ruby/site_ruby/1.8/rubygems/package.rb:547:in `read'
> C:/ruby/lib/ruby/site_ruby/1.8/rubygems/package.rb:547:in `zipped_stream'
> C:/ruby/lib/ruby/site_ruby/1.8/rubygems/package.rb:525:in `each'
> C:/ruby/lib/ruby/site_ruby/1.8/rubygems/package.rb:523:in `each_entry'
> C:/ruby/lib/ruby/site_ruby/1.8/rubygems/package.rb:438:in `loop'
> C:/ruby/lib/ruby/site_ruby/1.8/rubygems/package.rb:438:in `each_entry'
> C:/ruby/lib/ruby/site_ruby/1.8/rubygems/package.rb:423:in `each'
> C:/ruby/lib/ruby/site_ruby/1.8/rubygems/package.rb:523:in `each'
> C:/ruby/lib/ruby/site_ruby/1.8/rubygems/format.rb:56:in `from_io'
> C:/ruby/lib/ruby/site_ruby/1.8/rubygems/format.rb:53:in `open_from_io'
> C:/ruby/lib/ruby/site_ruby/1.8/rubygems/package.rb:689:in `open_from_io'
> C:/ruby/lib/ruby/site_ruby/1.8/rubygems/format.rb:53:in `from_io'
> C:/ruby/lib/ruby/site_ruby/1.8/rubygems/format.rb:41:in `from_file_by_path'
> C:/ruby/lib/ruby/site_ruby/1.8/rubygems/installer.rb:46:in `install'
> C:/ruby/lib/ruby/site_ruby/1.8/rubygems/remote_installer.rb:362:in `install'
> C:/ruby/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:164:in `execute'
> C:/ruby/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:129:in `each'
> C:/ruby/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:129:in `execute'
> C:/ruby/lib/ruby/site_ruby/1.8/rubygems/command.rb:49:in `invoke'
> C:/ruby/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:90:in `process_args'
> C:/ruby/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:63:in `run'
> C:/ruby/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:9:in `run'
> C:/ruby/bin/gem:11
> 
> [C:\ruby\lib\ruby\gems\1.8\gems]
> 
> Thanks!
> 
> "Chad Fowler" <chadfowler / gmail.com> wrote in message
> news:a2347a0405020712094dfee11f / mail.gmail.com...
>> On Tue, 8 Feb 2005 04:15:09 +0900, itsme213 <itsme213 / hotmail.com> wrote:
>> > Anyone having trouble with rubygems-update? I'm trying to update to
> 0.8.4 to
>> > try and fix some problems I seem to be having with 0.8.3.
>> >
>> > [C:\ruby\lib\ruby\gems\1.8\gems]gem --version
>> > 0.8.3
>> >
>> > [C:\ruby\lib\ruby\gems\1.8\gems]gem install rubygems-update
>> > Attempting local installation of 'rubygems-update'
>> > Local gem file not found: rubygems-update*.gem
>> > Attempting remote installation of 'rubygems-update'
>> > ERROR:  While executing gem ... (Zlib::BufError)
>> >     buffer error
>> >
>> >
>>
>> I haven't seen this one.  Can you add "--backtrace" to the command and
>> send the output?
>>
>>
>> Thanks!
>> -- 
>>
>> Chad Fowler
>> http://chadfowler.com
>> http://rubycentral.org
>> http://rubygarden.org
>> http://rubygems.rubyforge.org (over 50,000 gems served!)
>>
>>