Pe, Botp wrote:
> Shashank Date [mailto:sdate / everestkc.net] wrt:
>
> //> I'm sure I'm doing somethign wrong, but after having
> //installed this I
> //> get:
> //>
> //> C:\projects\ebill\aps\dist\tmp>ruby -e 'require "win32/sound"'
> //>
> //> c:/ruby/lib/ruby/site_ruby/1.8/i386-msvcrt/win32/sound.so: 126:
The
> //> specified module could not be found.   -
> //> c:/ruby/lib/ruby/site_ruby/1.8/i386-msvcrt/win32/sound.so
> //(LoadError)
> //> 	from
> //c:/ruby/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:
> //in `require'
> //> 	from -e:1
> //
> //Can you tell me the details of your system: OS, Ruby Version
> //etc. Better still what does this do:
> //
> //   C:\ruby>ruby -r rbconfig -e "include Config;
> //Dir.chdir(CONFIG['sitedir']+'/1.8/i386-msvcrt/win32'){puts
> //Dir['*.*']}"
> //
> //
> //FWIW, on my Win XP(Home) I get:
> //---------------------------------------
> //Microsoft Windows XP [Version 5.1.2600]
> //(C) Copyright 1985-2001 Microsoft Corp.
> //
> //
> //C:\>ruby -ve 'require "win32/sound"'
> //ruby 1.8.2 (2004-12-25) [i386-mswin32]
> //
> //C:\>
> //---------------------------------------
>
> I'm also getting the same error. fwiw, Before ruby puts the error, a
> messagebox  will pop saying "This application has failed to start
because
> MSVCR70.dll was not found." Reinstalling the application may fix this
> problem.

Confirmed.  We're working on it.  Thanks for the report.

Regards,

Dan