Jim Freeze said:
>> >  gem uninstall activerecord -v 1.8.0
>> >  Config file /Users/jdf/.gemrc does not exist
>> >  Attempting to uninstall gem 'activerecord'
>> >  You have requested to uninstall the gem:
>> >          activerecord-1.3.0
>> >          activerecord-1.4.0
>> >          activerecord-1.6.0
>> >          activerecord-1.5.1
>> >          activerecord-1.8.0
>> >  rails-0.9.2 depends on [activerecord (>= 1.3.0)]
>> >  If you remove this gem, the dependency will not be met.
>>
>> If you would have said "Yes, uninstall anyways", then the gem would have
>
> It looked to me that a 'Y' would have uninstalled
> activerecord-1.3.0-activerecord-1.8.0. IS this
> message going to be clearer in 1.8.7?

Hmmm ... it does look like it selected all the versions of activerecord,
not just the 1.8.0 version.  I will double check that code and make sure
the message is clearer.

Thanks for the feedback.

-- 
-- Jim Weirich     jim / weirichhouse.org    http://onestepback.org
-----------------------------------------------------------------
"Beware of bugs in the above code; I have only proved it correct,
not tried it." -- Donald Knuth (in a memo to Peter van Emde Boas)