Jim Freeze said:
> Gems is giving me fits with uninstalling activerecord,
> however, it uninstalls rails just fine.
>
>  gem uninstall activerecord -v 1.8.0
>  Config file /Users/jdf/.gemrc does not exist
>  Attempting to uninstall gem 'activerecord'
>  You have requested to uninstall the gem:
>          activerecord-1.3.0
>          activerecord-1.4.0
>          activerecord-1.6.0
>          activerecord-1.5.1
>          activerecord-1.8.0
>  rails-0.9.2 depends on [activerecord (>= 1.3.0)]
>  If you remove this gem, the dependency will not be met.

The current gems software is a bit sloppy in its dependency evaluations
while deleting.  While it is true that rails-0.9.2 has a dependency that
is satisified by activerecord-1.8.0, it apparent from the listed
dependencies that the dependency is also satisfied by all the versions
1.3.0 through 1.5.1.  Removing 1.8.0 shouldn't be a problem because there
are other versions of activerecord that can be used.

RubyGems 0.8.7 (out later this week) will handle this better.

>  Uninstall anyway? [yN]  n

If you would have said "Yes, uninstall anyways", then the gem would have
been uninstalled as you intended.

The CVS version of gems will only ask you about the /last/ gem that
satisfies a dependency.

-- 
-- Jim Weirich     jim / weirichhouse.org    http://onestepback.org
-----------------------------------------------------------------
"Beware of bugs in the above code; I have only proved it correct,
not tried it." -- Donald Knuth (in a memo to Peter van Emde Boas)