Hi

Gems is giving me fits with uninstalling activerecord,
however, it uninstalls rails just fine.

Here is what I get for rails:

 gem list rails
 Config file /Users/jdf/.gemrc does not exist
 
 *** LOCAL GEMS ***
 
 rails (0.9.5, 0.9.4.1, 0.9.3, 0.9.2, 0.9.1)
     Web-application framework with template engine, control-flow layer,
     and ORM.

 gem uninstall rails -v 0.9.1
 Config file /Users/jdf/.gemrc does not exist
 Attempting to uninstall gem 'rails'
 Successfully uninstalled rails version 0.9.1

Ok, fine, now for activerecord

 gem list activerecord
 Config file /Users/jdf/.gemrc does not exist
 
 *** LOCAL GEMS ***
 
 activerecord (1.8.0, 1.6.0, 1.5.1, 1.4.0, 1.3.0)
     Implements the ActiveRecord pattern for ORM.

 gem uninstall activerecord -v 1.8.0
 Config file /Users/jdf/.gemrc does not exist
 Attempting to uninstall gem 'activerecord'
 You have requested to uninstall the gem:
         activerecord-1.3.0
         activerecord-1.4.0
         activerecord-1.6.0
         activerecord-1.5.1
         activerecord-1.8.0
 rails-0.9.2 depends on [activerecord (>= 1.3.0)]
 If you remove this gem, the dependency will not be met.
 Uninstall anyway? [yN]  n
 ERROR:  While executing gem ... (Gem::DependencyRemovalException)
     Uninstallation aborted due to dependent gem(s)

 gem uninstall activerecord 
 Config file /Users/jdf/.gemrc does not exist
 Attempting to uninstall gem 'activerecord'
 
 Select RubyGem to uninstall:
  1. activerecord-1.3.0
  2. activerecord-1.4.0
  3. activerecord-1.5.1
  4. activerecord-1.6.0
  5. activerecord-1.8.0
  6. All versions
 > 5
 You have requested to uninstall the gem:
         activerecord-1.3.0
         activerecord-1.4.0
         activerecord-1.6.0
         activerecord-1.5.1
         activerecord-1.8.0
 rails-0.9.2 depends on [activerecord (>= 1.3.0)]
 If you remove this gem, the dependency will not be met.
 Uninstall anyway? [yN]  n
 ERROR:  While executing gem ... (Gem::DependencyRemovalException)
     Uninstallation aborted due to dependent gem(s)
 
Am I doing something wrong?

-- 
Jim Freeze
Code Red. Code Ruby