I'm on a fresh Fedora Core 3 box where my goal is to eventually have a 
FastCGI enabled version of Ruby On Rails.

I've installed Ruby from source.  When I attempt to install rubygems, 
however, I get the following error

$ ruby test/zlib/test_zlib.rb

returns instantly with no output.

irb reports "No such file to load -- zlib"

I'm guessing that this means that zlib isn't installed on my system.

But...

yum doesn't seem to be able to do anything with "zlib";  it does have a 
package called 'zip'.

The contents of the filesystem include the following:

/usr/share/doc/zlib-1.2.1.2
/lib/modules/2.6.9-1.667/build/include/linux/zlib.h
/lib/modules/2.6.9-1.667/build/include/config/zlib
/lib/modules/2.6.9-1.667/build/include/config/zlib/inflate.h
/lib/modules/2.6.9-1.667/build/include/config/zlib/deflate
/lib/modules/2.6.9-1.667/build/include/config/zlib/deflate/module.h
/lib/modules/2.6.9-1.667/build/lib/zlib_deflate
/lib/modules/2.6.9-1.667/build/lib/zlib_deflate/Makefile
/lib/modules/2.6.9-1.667/build/lib/zlib_inflate
/lib/modules/2.6.9-1.667/build/lib/zlib_inflate/Makefile
/lib/modules/2.6.9-1.667/kernel/lib/zlib_deflate/zlib_deflate.ko

----

This is highly similar to a reported bug at rubyforge:
http://rubyforge.org/tracker/index.php?func=detail&aid=1288&group_id=126&atid=575

However, I infer that was a debian system, since libzlib is at
http://packages.debian.org/stable/interpreters/libzlib-ruby

----

Can someone give me a pointer?  I've taken a bunch of stabs in the dark, 
but no success in any direction.


Thanks a bunch,

Jim