> I believe that this has to do with MySQL changing its authentication protocol.

Yes, if I recall correctly, Tomita Masahiro's MySQL-Ruby 2.5 library
only works with MySQL < 4.1 (we use 4.0.20 at work just fine).