System: alphaev6-osf4.0f

Ruby 1.6.2
   - Able to get core running after editing configure to use -std rather
than -ansi, although numerous warnings.
   - Unable to get Tk interface working (Tcl and Tk are installed on the
system).

Ruby 1.6.3
   - Unable to get core running using the default distribution or changes I
made for 1.6.2
   - Numerous "multiply defined" warnings leading to a stopped make.
   - Previous problems prevent looking at Tk.

Any tips for installation on the noted system would be appreciated. No gcc
or old libraries are installed on this system.