<jweirich / one.net> wrote in message
news:m2u24le2ro.fsf / skaro.access.one.net...
> >>>>> "Nathaniel" == Nathaniel Talbott <ntalbott / rolemodelsoft.com>
writes:
>
>     Nathaniel> [...] It should definitely be either:
>
>     Nathaniel>     assertInstanceOf(object, klass)
>     Nathaniel>     assertKindOf(object, klass)
>
>     Nathaniel> Or:
>
>     Nathaniel>     assertInstanceOf(klass, object)
>     Nathaniel>     assertKindOf(klass, object)
>
>     Nathaniel> [...] What does everyone else think?
>
>     Jim > I vote for the second option, again in the name of consistancy.
>
>     Jim > I do notice that we have ...
>
>     Jim > assertMatch(string, regexp)
>
>     Jim > which is counter to the above.  But then RUnit has it backwards
too.

I agree with Jim and Jimmy.  I think the assert(expected,actual) convention
is a good and it's one users of xUnit are accustomed to.  I also vote with
Jim that assertMatch could read assertMatch(regularExpression, string) in
the name of consistency.

One nit-picky note - naming the parameters in the message a little
differently might make the convention more evident to users of the
framework.

def assertInstanceOf(expectedClass, object, message="")
def assertKindOf(expectedClass, object, message="")


====================================================================
Duff O'Melia
RoleModel Software <http://www.rolemodelsoft.com>
342 Raleigh Street
Holly Springs, NC 27540