On 05:30 Fri 18 Feb     , Peter C. Verhage wrote:
> Hi,
> 
> Just found a small bug in Net::SSH 1.0. Line 44 of services.rb contains 
> the following if statement:
> 
>   if socket_name && socket_factory
> 
> If you use the Putty Agent the socket factory is enough for agent usage, 
> but because of this if statement you also have to set the SSH_AUTH_SOCK 
> environment variable to make use of the agent. This could be changed by 
> slightly changing the if statement to:
> 
>   if (File::ALT_SEPARATOR || socket_name) && socket_factory
> 
> Thanks for the great library BTW!
> 
> Regards,
> 
> Peter

Thanks for the fix, Peter. I've committed it to the repository
(http://www.jamisbuck.org/svn/net-ssh) and it will be released
whenever I get some time to package the next release. :)

- Jamis

-- 
Jamis Buck
jamis_buck / byu.edu
http://jamis.jamisbuck.org
------------------------------
"I am Victor of Borge. You will be assimil-nine-ed."