SASADA Koichi ha scritto:


> [ruby-dev:25658] ext/digest and libraries for crypto
> 
> Takahiro Kambe asked why Ruby requires openssl to build
> crypto libraries (such as md5, rmd160 and sha1).
> 
> Akinori MUSHA answerd to this question that it was because
> OpenSSL has platform independent APIs and it makes easy to
> maintain such libraries.

what kind of maintenance were the old libraries getting?
I supposed they were quite stable already.

I'm asking because the need to rely on openssl for this "basic" stuff,
makes me little nervous about breaking compat with platforms where this 
library is not common (i.e. on win32 )