On Fri, Mar 23, 2001 at 01:31:28AM +0900, Nathaniel Talbott wrote:
> Hmmm... you're right. Now I'm not sure which it should be, since
> assertKindOf() and assertInstanceOf() are contradictory. It should
> definitely be either:
> 
> 	assertInstanceOf(object, klass)
> 	assertKindOf(object, klass)
> 
> Or:
> 
> 	assertInstanceOf(klass, object)
> 	assertKindOf(klass, object)
> 
> Based on what you said, I'm leaning towards the latter. What does everyone
> else think?

I agree with the latter.  It's consistent, as Aaron said, with
the assert(expected,actual) convention.  Consistency is great!
:)

Jimmy

-- 
jjthrash SPAM pobox SPAM com