I had the same problem. What's going on is that os x has 1.6 and you
installed the new 1.8.2. HOWEVER, this does not over write the older
version. SO you are running into path issues.

to change this, check out the following article:

http://wiki.rubyonrails.com/rails/show/SettingYourPath

Hope this helps...have fun with ruby!