Okay. Here's the latest. (And boy, is this a pain in the ass.)

I went and downloaded the latest 1.8.2 build of Ruby -- the DMG
installer version from http://homepage.mac.com/discord/Ruby/

That's in. I, too, also noticed that there was a 1.6 folder inside of
/usr/local/lib/ruby/site_ruby/1.6 -- I deleted this directory.

Remaining is /usr/local/lib/ruby/1.8

Downloaded the latest RubyGems version 0.8.4

Based on a tidbit from a piece I read on installing Ruby and Ruby on
Rails from http://www.splashed.org/archives/2004/08/23/installing, I
also created a directory at /usr/local/lib/ruby/gems/1.8 -- there was a
note that not having this caused someone some grief when installing
RubyGems.

I then ran the following command from the RubyGems directory:

  sudo ruby setup.rb all

And got the following error:

setup.rb:52:in `require': No such file to load -- rbconfig (LoadError)
        from setup.rb:52

This is different from the ruby/1.6 errors I was getting prior to
deleting that install (which, btw, I'm still stumped as to how it got
there).

Anyone have any further ideas?

Would love to get this installed today...