Eric Hodel wrote:
> On 08 Feb 2005, at 00:15, AnthonyBaker wrote:
> 
>> Hey Folks,
>>
>> Am working on installing Ruby On Rails on my PowerBook (OS X 10.3.5).
>> Have downloaded Ruby 1.8.2 and then RubyGems 0.8.4, but when doing "gem
>> install rails" from the command line, I get the following error:
>>
>> /usr/local/lib/ruby/site_ruby/1.6/rubygems.rb:2:in `require': No such
>> file to load -- rbconfig (LoadError)
>>         from /usr/local/lib/ruby/site_ruby/1.6/rubygems.rb:2
>>         from /usr/bin/gem:3:in `require'
>>         from /usr/bin/gem:3
>>
>> Anyone have any ideas?
> 
> 
> You will need to upgrade to at least ruby 1.8.1 to get Rails to run.  
> Since it is late, I can't dig up the exact instructions for OS X, but 
> I'm sure somebody will chime in shortly.


I'm not a Mac  person, but after installing Ruby 1.8.2, how does one 
"upgrade" to Ruby 1.8.1?  :)

Anyway, it appears that there is a path issue, as Ruby 1.6 (or parts of 
it) is on the machine and is getting in the way.  (I'm assuming, of 
course, that "[h]ave downloaded Ruby 1.8.2" also means "... and 
installed it.")

Can one just delete the 1.6 sub-tree?  It also seems that rubygems 
installed itself in the 1.6 tree.  Odd.  (Think different?)

Does 1.6 have to be uninstalled before installing 1.8, on OS X?

James