Ryan Davis <ryand-ruby / zenspider.com> wrote:
> 
> On Jan 31, 2005, at 6:40 PM, Trans wrote:
> 
> > ...There are times when
> > I just want one method that does a number of different but related
> > things...
> 
> I gotta say wrt your original motivation, to me the need for this 
> "feature" reeks of bad design. Even ignoring Eric's appeal for 
> readability/separation of tokens, wanting a single method that "does a 
> number of different but related things" says to me that maintainability 
> and comprehensibility is going to be sacrificed in the medium-to-long 
> run.

http://cgi.bramwell.plus.com/krblog/2004/07/avoid_boolean_p.html is a
thought provoking read on adding-to-the-api versus adding-to-the-arglist

martin