Esteban Manchado Vel?zquez wrote:
> Hi all,
> 
>    First of all, I love Ruby and I'm _not_ trolling with this message :-)

Good start!

> 
>    Perhaps it's just a matter of Ruby being a young language, but I find it
> too common that you have to use newer versions of Ruby for "many" (for some
> definition of "many") application/libraries to work.

Well, I'm guessing you mean "many" to mean "a lot, maybe most", or this 
wouldn't be an issue.

> 
>    Of course, I can understand that for large applications, you may want to
> rely on "advanced" features/libraries from the newer versions of the Ruby
> distribution, but I find it frankly annoying that "many" applications require
> a relatively new version of Ruby.

I can understand that, though for many Rubyists 1.8.2 has a been a long 
time coming, and people have been working and playing with 1.7 , 1.8.x, 
and previews of 1.8.2  prior to the final release.  There is a good 
chance that new features or fixes are in 1.8 precisely because of this, 
and the people pushing for these changes tend to be the same ones 
writing a good many applications.

> 
>    In particular, to use RoR, it seems that you need not only 1.8.x, but 1.8.1
> or higher. And, moreover, upgrading the version of RoR breaks applications. Is
> it really necessary breaking compatibility? Is this situation that way only
> because RoR is < 1.0? David?

What breaks, other than Rails apps, if you update your version of Rails?

(I can't speak for David, but I believe that if an application or 
framework is pre version 1 then all bets are off, until there comes a 
release candidate or something along those lines.  I also think David 
and Co. have been very good about minimizing breakage, and explaining 
the steps to take to fix said breakage.)

> 
>    The thing is, many people _can't_ (or don't want to) upgrade their Ruby
> interpreter, so we're raising the bar here for the adoption of Ruby :-( For
> example, people using Debian stable (flames to /dev/null, please) _can't_
> upgrade their Ruby interpreters. If they did, they would lose the benefits of
> "automatic" security upgrades.

I'd be interested in some rough figures, as my limited impression is 
that getting and installing Ruby is dead simple, so the main barriers 
would be personal choice or company policy, and that most Rubyists 
exercise the option to update when there is a new stable version.

> 
>    And, of course, that mostly fine for _developers_ who happen to administer
> the machines they work on, but when administrator and developer aren't the
> same person or don't share the same interests, the administrator usually
> doesn't give a #### (insert your favourite four-letter bad word here) about
> having a recent Ruby interpreter (WTF?).
> 
>    So, I wanted to share these thoughts with you all, and wondered what are
> your thoughts on this....

There's a certain chicken-and-egg thing here.  Some apps would be harder 
to write and distribute if they relied on Ruby 1.6; they might not ever 
get written, so the motivation to get Ruby would be less.  I think the 
adoption of Ruby is driven by a combination of language features (which 
have improved with each version) and available apps and libs (the number 
of which grows more plentiful with each version of Ruby).  It can be a 
drag to have to forgo using new shiny apps because they mandate Ruby 
1.8.2 but, overall, more people are benefiting this way.

Question for the group: Is there a lib or something that one could 
install to boost a default 1.6 Ruby installation into behaving as if it 
were 1.8?  A shim of some sort, one that doesn't require you to be root?

James