I'm trying to download packages via rubygems, but only a subset of the
packages that are available on the rubygems site are showing up when I
do queries.

The list at the bottom of this message is what I get when I issue the
"gem query --remote" command.  However, if I go directly to the
"http://gems.rubyforge.org/gems/" site, there are a number of other
packages listed which don't show up when I do the query.

I also see all those other packages when I look in the yaml index
at "http://gems.rubyforge.org/yaml".

Does anyone know why my version of rubygems would be ignoring some of
the packages that are listed on the site?  For example, the "wee"
package doesn't show up in the listing below, although it does appear on
the site and in the yaml file, and other people seem to be able to see
it and download it via the rubygems system.

Thanks in advance.

Here's what I did:

 # gem --version
 0.8.4
 # gem query --remote

  *** REMOTE GEMS ***

  cgikit (1.1.0)
      CGIKit is a componented-oriented web application framework like
      Apple Computers WebObjects.  This framework services
      Model-View-Controller architecture programming by components based
      on a HTML file, a definition file and a Ruby source.  

  copland (0.8.0, 0.1.0)
      Copland is an "Inversion of Control" (IoC, also called "Dependency
      Injection") container for Ruby, based heavily on the HiveMind
      container for Java. It supports both type-2 (setter) and type-3
      (constructor) injection.

  coverage (0.1)
      identifies inactive code

  dbdbd (0.2.2)
      dbdbd (David Black's Database Definer) -- for ad hoc flat-file
      database formats

  iterator (0.5)
      bidirectional external iterators

  jabber4r (0.7.0)
      Jabber4r is a pure-Ruby Jabber client library

  lafcadio (0.3.4)
      Lafcadio is an object-relational mapping layer

  Linguistics (1.0.2)
      This is a generic, language-neutral framework for extending Ruby
      objects  with linguistic methods.

  log4r (1.0.5)
      Log4r is a comprehensive and flexible logging library for Ruby.

  net-ssh (0.1.0)
      Net::SSH is a pure-Ruby implementation of the SSH2 client protocol.

  Ook (1.0.2)
      A Ruby interpreter for the Ook!
      (www.dangermouse.net/esoteric/ook.html) and BrainF*ck
      (www.catseye.mb.ca/esoteric/bf/index.html) programming languages.

  progressbar (0.0.3)
      Ruby/ProgressBar is a text progress bar library for Ruby.  It can
      indicate progress with percentage, a progress bar, and estimated
      remaining time.

  RedCloth (2.0.2)
      RedCloth is a module for using Textile in Ruby. Textile is a text
      format. A very simple text format. Another stab at making readable
      text that can be converted to HTML.

  rublog (0.8.0)
      RubLog is a simple web log, based around the idea of displaying a
      set of regular files in a log-format.

  RubyJDWP (0.0.1)
      Ruby implementation of the Java Debug Wire Protocol. This version is
      pre-alpha.

  sqlite (1.1.3)
      SQLite/Ruby is a module to allow Ruby scripts to interface with a
      SQLite database

  statistics (2001.2.28)
      module Math::Statistics provides common statistical functions
  #


-- 
 Lloyd Zusman
 ljz / asfast.com
 God bless you.