By sheer chance I tried to compile the so called stable snapshop on HP-UX 11
with gcc 2.95.2 after getting frustrated by the fact, that version 1.6.2
didn't compile with optimizations.

Well - everything seems to work fine with -O2.

So I am wondering, when will you release the snapshot as a stable release?
Or are there any cons (features broken in the snapshot which are not in
1.6.2) against that move? It is hard to persuade colleagues to jump on an
unoffical ruby train otherwise.

Is it worth to update the ruby FAQ concerning installation on HP-UX?

Regards,
Lars