Hi all,

This is a ruby-dev summary in these days.


[ruby-dev:25430] 1.8 warn nonblocking IO#read and add IO#readpartial

  Akr suggested to make changes of IO in ruby 1.8:

    * warn when you use nonblocking IO#read
    * add a new method IO#readpartial

  But Tomita raised an objection to add warning to 1.8 stable version
  ([ruby-dev:25443]). If correct scripts in 1.8.2 become "broken"
  in 1.8.3, many users and developers will be confused and they think
  that Ruby is not a stable language.  However, mput pointed out that
  Ruby change its specification in stable version (ex. between 1.8.1
  and 1.8.2). Matz admitted that there are some (non-critical) incompatible
  changes and some of them are on purpose.

  Akr made a modified suggestion that warnings are raised with
  -w option.



# ruby-dev summary index:
# http://i.loveruby.net/en/ruby-dev-summary.html

Regards,

Masayoshi 'Maki' Takahashi     E-mail: maki / rubycolor.org