Hi all,
I am trying to install mysql-ruby-2.4.4 on my Fedora Core 3 with ruby
1.8.2 (2004-12-25) [i686-linux] (gcc (GCC) 3.4.2 20041017 (Red Hat
3.4.2-6.fc3)). Following the instructions at
http://tmtm.org/en/mysql/ruby/ I got the following scenario:

[mark@localhost mysql-ruby-2.4.4]$ ruby extconf.rb
checking for mysql_query() in -lmysqlclient... yes
checking for mysql.h... no
checking for mysql/mysql.h... yes
creating Makefile
extconf.rb:33: uninitialized constant CPP (NameError)

As you can see I get the error at line 33. Looking at that line I see
the assignment:
cpp = Config::expand sprintf(CPP, $CPPFLAGS, $CFLAGS, '')

Here my very limited understanding ends. How can I solve this issue,
there is probably some problem related to the compiler but I don't now
what to do to solve it. Please advice if you can.

I tried also to install ruby-mysql-0.2.5 and it was installed 
succesfull. But when I tried the test.rb I got the following error: 

[root@localhost ruby-mysql-0.2.5]# ruby test.rb localhost myusername
mypassword
connect............../mysql.rb:453:in `read': Client does not support
authentication protocol requested by server; consider upgrading MySQL
client (Mysql::Error)
        from ./mysql.rb:130:in `real_connect'
        from ./mysql.rb:91:in `initialize'
        from ./mysql.rb:1085:in `new'
        from ./mysql.rb:1085:in `connect'
        from ./t/00connect.rb:1
        from test.rb:23:in `load'
        from test.rb:23
        from test.rb:19:in `each'
        from test.rb:19
I have the latest stable version of MySQL: 4.1.9.
Could you help also on this point?

What's wrong with my attempts to let MySQL and Ruby happily communicate?

Thanks in advance,
Mark

Inviato da www.mynewsgate.net