Hello all...

I noticed something the other day.

In the Queue and SizedQueue classes in thread.rb,
we find this definition.

  def shift(non_block=false)
    pop(non_block=false)
  end

Surely that should say  pop(non_block) instead???

I'm at a loss as to why alias wasn't used, especially since 
it is used on the very next line...

Hal Fulton