Thursday wrote:
> I'm running into an error when installing RubyGems on new Linux box 
> using Ruby 1.8.2 2005-01-06 snapshot.
> 
> I issue 'ruby setup.rb all' as root and get the following error:
> 
> [SNIP]
> ---> lib/rubygems
> mkdir -p /usr/local/lib/ruby/site_ruby/1.8/rubygems
> install builder.rb /usr/local/lib/ruby/site_ruby/1.8/rubygems
> [SNIP]
> /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:26:in 
> `require': No such file to load -- rubygems/builder (LoadError)
>     from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:58:in `manage_gems'

The solution was to recompile/reinstall ruby after installing zlibc. 
The new linux box was missing zlibc at the time ruby was compiled so 
ruby didn't have it.

Since the setup.rb error message didn't indicate zlibc as the problem, 
it was a royal pain to track down.