henon (meinrad recheis) wrote:
> Curt Hibbs wrote:
> 
>> If you have FXRuby 1.0.29 or earlier, you do a require "fox". If you have
>> FXRuby 1.2.2, you must do a require "fox12". Perhaps this is the problem.
>>
>> Curt
>>
> 
> Thanks for pointing this out. foxGUIb is currently based on FXRuby 
> 1.0.29. I did never test it with FXRuby 1.2.2.
> 
> Porting to the new FXRuby version is one of the next big tasks for me.
> - henon
> 
> 

Actually it's not that big a task. I went through the same migration
for the FreeRIDE application some time ago and, although FreeRIDE is
quite a large application, it only took more a few hours of work to
make the necessary changes.

The best thing to is to go through Lyle Johnson's excellent document
step by step and apply the changes as described. (see
http://www.knology.net/~lyle/fox/1.2/WhatsNew.html-toc.html)

And by the way, having foxGUIb ported to FOX 1.2 would be a good start
for a tighter integration with the FreeRIDE Ruby IDE. That would be 
really
cool!

Laurent