"henon (meinrad recheis)" <meinrad.recheis__nospam__ / gmx.at> wrote:
> Curt Hibbs wrote:
> > If you have FXRuby 1.0.29 or earlier, you do a require "fox". If you have
> > FXRuby 1.2.2, you must do a require "fox12". Perhaps this is the problem.
> > 
> > Curt
> 
> Thanks for pointing this out. foxGUIb is currently based on FXRuby 
> 1.0.29. I did never test it with FXRuby 1.2.2.
> 
> Porting to the new FXRuby version is one of the next big tasks for me.

FWIW, it doesn't currently work with 1.2 - I got the following (after
changing all 'require fox' to 'require fox12') :

$ ruby foxGUIb.rbw
../FX/fxbase.rb:386: uninitialized constant Fox::FXMenubar (NameError)
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in `r
equire__'
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in `r
equire'
        from ./__FX__.rb:6
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in `r
equire__'
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in `r
equire'
        from foxGUIb.rbw:12

This is with the latest one-click installer.

martin