If you have FXRuby 1.0.29 or earlier, you do a require "fox". If you have
FXRuby 1.2.2, you must do a require "fox12". Perhaps this is the problem.

Curt

> -----Original Message-----
> From: "Luis G. G?mez" [mailto:lgomez / vfxnetwork.com]
> Sent: Wednesday, January 05, 2005 8:27 AM
> To: ruby-talk ML
> Subject: Re: [ANN] foxGUIb - Interactive Fox GUI Builder and Code
> Generator
>
>
> I get:
>
> c:/ruby/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in
> `require__': No such file to load -- fox (LoadError)
>          from
> c:/ruby/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in `require'
>          from ./__FX__.rb:1
>          from
> c:/ruby/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in
> `require__'
>          from
> c:/ruby/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in `require'
>          from foxGUIb.rbw:12
>
> When trying to run foxGUIb.rbw
>
> Any sugestions?
>
> henon (meinrad recheis) wrote:
> > foxGUIb is an interactive gui builder for fxruby written
> entirely in Ruby.
> > It does not require much knowledge of the FXRuby API and therefore is
> > also a good start for fxruby newbies. foxGUIb is a completely
> redesigned
> > and rewritten version of the fox-tool project.
> >
> > Check out the Project Wiki for details and documentation.
> >
> > http://fox-tool.rubyforge.org/wiki/wiki.pl?
> >
> > or the project site at rubyforge
> >
> > http://www.rubyforge.org/projects/fox-tool
> >
> > I have been using foxGUIb myself for a about a year at work before I
> > prepared it for release to the public. I consider it especially useful
> > because you can tweak your fxruby user interfaces interactively
> and that
> > preserves a lot of time, fox-api reading and finger typing.
> >
> > -henon
> >
>
> --
> No virus found in this incoming message.
> Checked by AVG Anti-Virus.
> Version: 7.0.300 / Virus Database: 265.6.8 - Release Date: 1/3/2005
>