Curt Hibbs wrote:
>
> Johan Nilsson wrote:
> >
> > "Curt Hibbs" <curt / hibbs.com> wrote in message
> > news:EAENKKNOJPMNCDMLDOMLMEJMHEAA.curt / hibbs.com...
> > > Finally, after what seemed to be an endless series
> > > of release candidates, I am happy to announce the
> > > final release of version 182-14. Happy New Year!
> > >
> >
> > I don't know if it's only me, but the installer doesn't seem to
> update the
> > path properly. After deinstalling 1.8.2-14 RC9 and installing the final
> > release I'm no longer able to simply execute 'ruby' from the
> command line.
> > Starting FreeRIDE also complains about missing rubyw. Simply running a
> > script by e.g. "sample.rb" seems to work fine.
> >
> > I installed as a user with administrative rights on two
> machines, and the
> > same problem applies to both. What's probably worth noting is
> that neither
> > of these accounts is the default adminstrative account.
> >
> > Platform is WinXP Pro SP1 / SP2 (on the two machines I've tried).
>
> You may need to reboot your machine after installation. Normally
> this is not
> necessary, but I've noticed that a small percentage of the time,
> the updated
> path does not appear to take affect until after a restart. For me, it
> happens rarely, and I've never been able to discern any pattern as to when
> this will occur.

If restarting doesn't work, there's another possibility.

The installer runs a tiny little app written in C that adds <ruby>\bin to
your existing path. Its conceivable that something that already exists in
you path is causing this app to malfunction. If restarting does not work,
send me you path so that I can test out this possibility.

Curt



-- 
No virus found in this outgoing message.
Checked by AVG Anti-Virus.
Version: 7.0.298 / Virus Database: 265.6.7 - Release Date: 12/30/2004