On Mon, 12 Mar 2001, Luigi Ballabio wrote:

> > > They have been used in the functional programming community for years with
> > > these names (which doesnt mean we have to adopt them...). I'd say tail
> > > is a good name and a very useful method. 'init' is probably too close to
> > > 'initialize' so not good name. IMHO, 'zip' is a pretty good name (think
> > > about a zipper in your pants or jacket...) but I'm not sure the
> > > functionality is useful enough to promote it into the base lib.
> >
> >How about 'head'  instead of 'init'?
> 
> I think the name is already in use in functional programming with a 
> different meaning:
> 
> [1,2,3,4].head                       # => either 1 or [1], I don't remember
> 
in Haskell head([1,2,3,4]) would evaluate to 1.

/Robert