I am trying to use BlueCloth markdown in a website.

I installed the BlueCloth gem as root:

$> gem install bluecloth --rdoc

Everything seemed to go fine. If I go into irb, I can:

irb(main):003:0> require 'rubygems'
=> true
irb(main):004:0> require_gem "BlueCloth"
=> true
irb(main):005:0> b = BlueCloth.new( "*abcd*" )
=> "*abcd*"

However, when I:

require 'rubygems'
require_gem 'BlueCloth'

From within a .rhtml file, it fails at the require_gem line with the
following error:

[Fri Dec 17 16:01:46 2004] [error] mod_ruby: error in ruby
[Fri Dec 17 16:01:46 2004] [error] mod_ruby:
/usr/local/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:63:in
`directory?': Insecure operation - directory? (SecurityError)
[Fri Dec 17 16:01:46 2004] [error] mod_ruby:   from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:63:in
`search_loadpath'
[Fri Dec 17 16:01:46 2004] [error] mod_ruby:   from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:63:in
`delete_if'
[Fri Dec 17 16:01:46 2004] [error] mod_ruby:   from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:63:in
`search_loadpath'
[Fri Dec 17 16:01:46 2004] [error] mod_ruby:   from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:4:in
`require'
[Fri Dec 17 16:01:46 2004] [error] mod_ruby:   from
/usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:261:in `default_dir'
[Fri Dec 17 16:01:46 2004] [error] mod_ruby:   from
/usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:86:in `dir'
[Fri Dec 17 16:01:46 2004] [error] mod_ruby:   from
/usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:248:in `set_paths'
[Fri Dec 17 16:01:46 2004] [error] mod_ruby:   from
/usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:97:in `path'
[Fri Dec 17 16:01:46 2004] [error] mod_ruby:   from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/cache.rb:31:in
`from_installed_gems'
[Fri Dec 17 16:01:46 2004] [error] mod_ruby:   from
/usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:75:in `cache'
[Fri Dec 17 16:01:46 2004] [error] mod_ruby:   from
/usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:109:in `activate'
[Fri Dec 17 16:01:46 2004] [error] mod_ruby:   from
/usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:34:in `require_gem'
[Fri Dec 17 16:01:46 2004] [error] mod_ruby:   from
/home/recipe/public_html/test.rhtml:21
[Fri Dec 17 16:01:46 2004] [error] mod_ruby:   from (eval):0
[Fri Dec 17 16:01:46 2004] [error] mod_ruby:   from
/usr/local/lib/ruby/1.8/apache/eruby-run.rb:116:in `eval_string_wrap'
[Fri Dec 17 16:01:46 2004] [error] mod_ruby:   from
/usr/local/lib/ruby/1.8/apache/eruby-run.rb:116:in `run'
[Fri Dec 17 16:01:46 2004] [error] mod_ruby:   from
/usr/local/lib/ruby/1.8/apache/eruby-run.rb:72:in `handler'


I restarted my webserver after installation of BlueCloth, but that
didn't help.  Any idea how to get this gem to work within
eruby/mod_ruby?